3.1 RecTrac Update.exe is hanging. V3_Install Log: "Extracting and Restoring Staging Database"
Problem
When running the RecTrac 3.1.09.00 update, the update hangs. The last entries in the V3_Install.log file are similar to the following:
mm/dd/yyyy - HH:MM:SS *- Extracting and Restoring Staging Database
What is the cause of this, and how can we resolve it in order to run the update?
Solution
Cause
The 3.1.09.00 update is expecting to find a RecTrac DEMO database installed and running on the server along with the RecTrac LIVE database. This error is a result of the Demo Database not being found.
If your configuration has been modified to have on a LIVE production database on the server, then you will need to adjust a Windows Registry Key in order for the 3.1.09.00 update to run.
Having separate environments for LIVE and DEMO is not a common setup, but for those customers who have a Testing environment separate from a Production environment, this might be a factor. VSI advises that you check the Registry prior to running the 3.1.09.00 executable.
Note: This does NOT apply to customers who are fully hosted with Vermont Systems.
Resolution
- Log onto your RecTrac server as an Administrator.
- In Windows Explorer, browse to <X>:\VSI3\RecTrac\Data\DEMO, where <X> is the mapped partition on which RecTrac is installed.
-
Verify that no demo database exists and that you do not have demo database files. If <X>:\VSI3\RecTrac\Data\DEMO is empty, or if it does not exist, then you do not have a demo database on the server. Proceed to the next step.
- If you do have a <X>:\VSI3\RecTrac\Data\DEMO folder, and if there are no files in it and there should be, then stop now and contact Vermont Systems Operations for assistance. DO NOT proceed to the next step.
- On your keyboard, press <Windows key> + r. This will launch the Run window.
- Enter 'Regedit' in the Open field and press 'Enter' or click OK.
-
Make a backup of the Windows Registry
- Highlight/Select 'Computer.
- Click File Export.
- Enter a file name and save the backup to some place safe.
- In the Registry Key, go to HKEY_LOCAL_MACHINE SOFTWARE VSI3 RECTRAC.
- Delete the "DIR_DEMO Directory" Registry Key.
- Go to HKEY_LOCAL_MACHINE SOFTWARE VSI3 RECTRAC DATABASES.
- Delete the "DB_2 " Registry Key that points to <X>:\VSI3\RECTRAC\DATA\DEMO.
- Edit the "DB_Counter" Value Data from 2 (two) to 1 (one).
- Exit the Registry Key. VSI recommends restarting the Server whenever a change to the Registry is made.
- Run the Setup_3.1.09.00.exe per instructions in the RT3.1 Minor Version Update.pdf